summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-03 17:35:57 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:10 +0100
commit8cea282efe5caf9dda2980422e789a7e013b816a (patch)
treedf5050d7ef5cfa74273e0894b3131cedbf263ef7
parentfc92d33932cd3b581c9085c03751ae4f01ade04b (diff)
downloadguix-patches-8cea282efe5caf9dda2980422e789a7e013b816a.tar
guix-patches-8cea282efe5caf9dda2980422e789a7e013b816a.tar.gz
gnu: Add python-supersmoother.
* gnu/packages/python-science.scm (python-supersmoother): New variable. Change-Id: I8fb43d746757014e3b773c07458b777b893adb4a
-rw-r--r--gnu/packages/python-science.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 6fd4f555fa..e1e6ba90f1 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2607,6 +2607,31 @@ interoperability offered by HDF5.")
proportional-integral-derivative} controller.")
(license license:expat)))
+(define-public python-supersmoother
+ (package
+ (name "python-supersmoother")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch) ; no package in PyPI
+ (uri (git-reference
+ (url "https://github.com/jakevdp/supersmoother")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lkj8l2mpki6x2pxcwlrplx63lhi8h9v2rzxgjfb0cppsfr8m1wp"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy))
+ (native-inputs (list python-scipy))
+ (home-page "http://github.com/jakevdp/supersmoother")
+ (synopsis "Python implementation of Friedman's Supersmoother")
+ (description
+ "This package provides an efficient implementation of
+@url{https://www.slac.stanford.edu/pubs/slacpubs/3250/slac-pub-3477.pdf,
+Friedman's SuperSmoother} based in Python. It makes use of numpy for fast
+numerical computation.")
+ (license license:bsd-2)))
+
(define-public python-opt-einsum
(package
(name "python-opt-einsum")