summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-03 18:35:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:12 +0100
commit725d92f54ade087246fd3c9443fa4444e0309b66 (patch)
treeaf94d1c3b3f97a70ea6291de57590a3dbfd9adcd
parentb332e7b85e56957e494dacf5f15edd6f4e8464b9 (diff)
downloadguix-patches-725d92f54ade087246fd3c9443fa4444e0309b66.tar
guix-patches-725d92f54ade087246fd3c9443fa4444e0309b66.tar.gz
gnu: python-bayesicfitting: Refresh package style.
* gnu/packages/astronomy.scm (python-bayesicfitting): Adjust indentation. [build-system]: Swap to pyproject-build-system. [arguments] <#:test-flags>: Add them. <#:phases>: Use test flags in 'check phase. Change-Id: Iffc8591199bbaf2a0da95b6b22476e34121dbe79
-rw-r--r--gnu/packages/astronomy.scm42
1 files changed, 24 insertions, 18 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 670e8510d8..38e3c2fa0c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1934,25 +1934,31 @@ specifically in the C code.")
(package
(name "python-bayesicfitting")
(version "3.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dokester/BayesicFitting")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0q6v7w9b1xzam0qn5vsl5wrdp1fkfpsn411pzd8wyy9giznpajxi"))))
- (build-system python-build-system)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dokester/BayesicFitting")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q6v7w9b1xzam0qn5vsl5wrdp1fkfpsn411pzd8wyy9giznpajxi"))))
+ (build-system pyproject-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "unittest" "discover"
- "test")))))))
- (propagated-inputs (list python-astropy python-future python-matplotlib
- python-numpy python-scipy))
+ (list
+ #:test-flags #~(list "-m" "unittest" "discover" "test")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (when tests?
+ (apply invoke "python" test-flags)))))))
+ (propagated-inputs
+ (list python-astropy
+ python-future
+ python-matplotlib
+ python-numpy
+ python-scipy))
(home-page "https://www.bayesicfitting.nl")
(synopsis "Python Toolbox for Astronimical Bayesian fitting")
(description