summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2024-04-19 16:22:28 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-04-19 21:22:06 +0800
commite9e60b3a1dd2f88da4e1634e1c0f73077054aca6 (patch)
treed81f46616567c8facf10739671c594a73257ef73
parent174014c23f2329e285ee1b54d2d0b4b01ab47990 (diff)
downloadguix-patches-e9e60b3a1dd2f88da4e1634e1c0f73077054aca6.tar
guix-patches-e9e60b3a1dd2f88da4e1634e1c0f73077054aca6.tar.gz
gnu: Add font-lxgw-heartserif.
* gnu/packages/fonts.scm (font-lxgw-heartserif): New variable. Change-Id: I94cab117c35c536526e8f88d7ba05a3e6b5747d5 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/fonts.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index f4084c01ee..26697a4e40 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3467,6 +3467,36 @@ from IPAmj Mincho, modified to adapt to the standard glyph shape used in
Mainland China.")
(license license:ipa)))
+(define-public font-lxgw-heartserif
+ (package
+ (name "font-lxgw-heartserif")
+ (version "0.920.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+ version "/LXGWHeartSerif.ttf"))
+ (sha256
+ (base32 "1nbhvy0b9vb0w5pfpp5f0jdkb6fs422avkdxzqydmv74g5v8gz07"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let ((out #$output)
+ (dest (string-append #$output "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/LXGHeartSerif.ttf")))))
+ (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+ (synopsis "Simplified Chinese Song typeface derived from Kokoro Mincho")
+ (description "LXGW HeartSerif is a Simplified Chinese Song typeface derived
+from Kokoro Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+ (license license:ipa)))
+
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")