summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2024-04-19 16:22:27 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-04-19 21:20:30 +0800
commit174014c23f2329e285ee1b54d2d0b4b01ab47990 (patch)
tree78c485a27f751d7df68ec0d4e759c4722018ee31
parentee64afca1f1c62a5dd1cde6cde6fde8d041fa693 (diff)
downloadguix-patches-174014c23f2329e285ee1b54d2d0b4b01ab47990.tar
guix-patches-174014c23f2329e285ee1b54d2d0b4b01ab47990.tar.gz
gnu: Add font-lxgw-neozhisong.
* gnu/packages/fonts.scm (font-lxgw-neozhisong): New variable. Change-Id: I351bb86a22ad610f51d6e0e8aea290285529cbd3 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/fonts.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 042368ef47..f4084c01ee 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3437,6 +3437,36 @@ within GB 2312, standard glyphs for Mainland China is used.")
Song typeface covering commonly used characters as well as written form of
dialects in Hong Kong and Taiwan.")))
+(define-public font-lxgw-neozhisong
+ (package
+ (name "font-lxgw-neozhisong")
+ (version "0.920.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+ version "/LXGWNeoZhiSong.ttf"))
+ (sha256
+ (base32 "02jv5ysd450i47m3qmdwm3w23bp4wlqrjdwk6iirhgpv169p901j"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let ((out #$output)
+ (dest (string-append #$output "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/LXGWNeoZhiSong.ttf")))))
+ (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+ (synopsis "Simplified Chinese Song typeface derived from IPAmj Mincho")
+ (description "LXGW NeoZhiSong is a Simplified Chinese Song typeface derived
+from IPAmj Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+ (license license:ipa)))
+
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")