summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Pieper <jpieper@mailbox.org>2024-04-15 19:45:04 +0200
committerGuix Patches Tester <>2024-04-17 14:14:49 +0200
commita0686eec3451348d8b408ea8e52e78221c829fdd (patch)
treee3f71ba027fac32ea9a5b2ae7de30bb867fa4280
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-a0686eec3451348d8b408ea8e52e78221c829fdd.tar
guix-patches-a0686eec3451348d8b408ea8e52e78221c829fdd.tar.gz
gnu: Add python-docstring-to-markdown.
* gnu/packages/python-xyz.scm (python-docstring-to-markdown): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..337b009672 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1376,6 +1376,25 @@ template")
variables into the markdown template")
(license license:expat)))
+(define-public python-docstring-to-markdown
+ (package
+ (name "python-docstring-to-markdown")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "docstring-to-markdown" version))
+ (sha256
+ (base32 "0gdpabnyl1kyy0cjrnph6xl4fyhgim50a1amsaqq3hahki6i2ip1"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python-lsp/docstring-to-markdown")
+ (synopsis "On the fly conversion of Python docstrings to markdown")
+ (description
+ "This module can convert Python docstrings to Markdown.
+It can recognise reStructuredText inside docstrings and convert multiple of its
+features to Markdown. It also includes initial support for Google-formatted docstrings.")
+ (license license:lgpl2.1+)))
+
(define-public python-mysql-connector-python
(package
(name "python-mysql-connector-python")