summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Pieper <jpieper@mailbox.org>2024-04-15 19:45:09 +0200
committerGuix Patches Tester <>2024-04-17 14:14:53 +0200
commit327823c2a36e74f57e7b2bb8fbbbc243d12f4ece (patch)
tree808282a82d65c9c81a54c73792c704f74918b772
parentbde414a5b48dded43d25e5fae3e9f43803ab0615 (diff)
downloadguix-patches-327823c2a36e74f57e7b2bb8fbbbc243d12f4ece.tar
guix-patches-327823c2a36e74f57e7b2bb8fbbbc243d12f4ece.tar.gz
gnu: python-rope: Update to 1.13.0.
* gnu/packages/python-xyz.scm (python-rope): Update to 1.13.0. [arguments]{disable-broken-tests}: Disable test_hint_or. [propagated-inputs]: Add python-pytoolconfig. Change-Id: I0717c76631ca744a0f601734f707f45fa05b62c2
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ee1453a17..0d78e56d5e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20050,31 +20050,33 @@ respectively.")
(define-public python-rope
(package
(name "python-rope")
- (version "1.1.1")
+ (version "1.13.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rope" version))
(sha256
- (base32
- "0bkzwkllxxdxd3w70xiy137lqvnlmmaplsc2ya3s23ss4kq8y10k"))))
+ (base32 "1078mkzivz45my8x2y5gxisr0vba630xj7yxx7anr068xhnpshsi"))))
(build-system python-build-system)
(arguments
- (list #:phases
- `(modify-phases %standard-phases
- (add-after 'unpack 'disable-broken-test
- (lambda _
- (substitute* "ropetest/contrib/autoimporttest.py"
- (("def test_search_module")
- "def __notest_search_module")
- (("def test_search_submodule")
- "def __notest_search_submodule")))))))
- (native-inputs
- (list python-pytest-timeout
- python-pytest))
+ (list
+ #:phases `(modify-phases %standard-phases
+ (add-after 'unpack 'disable-broken-test
+ (lambda _
+ (substitute* "ropetest/contrib/autoimporttest.py"
+ (("def test_search_module")
+ "def __notest_search_module")
+ (("def test_search_submodule")
+ "def __notest_search_submodule"))
+ (substitute* "ropetest/type_hinting_test.py"
+ (("def test_hint_or")
+ "def __notest_hint_or")))))))
+ (native-inputs (list python-pytest-timeout python-pytest))
+ (propagated-inputs (list python-pytoolconfig))
(home-page "https://github.com/python-rope/rope")
(synopsis "Refactoring library for Python")
- (description "Rope is a refactoring library for Python. It facilitates
+ (description
+ "Rope is a refactoring library for Python. It facilitates
the renaming, moving and extracting of attributes, functions, modules, fields
and parameters in Python source code. These refactorings can also be applied
to occurrences in strings and comments.")