summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2024-04-08 00:33:51 +0400
committerGuix Patches Tester <>2024-04-17 14:19:28 +0200
commita7f430c8f88d4acb5b146c7cddb8ce1a83bf95ff (patch)
treea5c28bfa0474d9482bbb84d03a19876fa0216ccc
parentd873ac95050658a644cfc5b41c75e846e58b847d (diff)
downloadguix-patches-a7f430c8f88d4acb5b146c7cddb8ce1a83bf95ff.tar
guix-patches-a7f430c8f88d4acb5b146c7cddb8ce1a83bf95ff.tar.gz
gnu: %opencl-sdk-version: Update to 2023.12.14.
This updates opencl-headers, opencl-clhpp and opencl-icd-loader. * gnu/packages/opencl.scm (opencl-headers)[source]: Update hash. [home-page]: Update URL. (opencl-clhpp)[source]: Update hash. (opencl-icd-loader)[source]: Update hash. Update origin URI to fix lint. Change-Id: I674fc8aa79d1d98bac7ff66ba3a0e0fcb9b243cb
-rw-r--r--gnu/packages/opencl.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index d6fb344458..b3d917d28b 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -53,7 +53,7 @@
;; together (lockstep) and must be updated together. The following variable
;; facilitates that.
-(define %opencl-sdk-version "2023.02.06")
+(define %opencl-sdk-version "2023.12.14")
(define-public opencl-headers
(package
@@ -67,13 +67,13 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
+ (base32 "13a5zv0nvjp66sswm6zdakmfjxp7536wplampbx9fa6q7i14lpy0"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
(description
"This package provides the C headers by Khronos for OpenCL programming.")
- (home-page "https://www.khronos.org/registry/OpenCL/")
+ (home-page "https://registry.khronos.org/OpenCL/")
(license license:asl2.0)))
(define (make-opencl-headers major-version subversion)
@@ -107,7 +107,7 @@
(url "https://github.com/KhronosGroup/OpenCL-CLHPP")
(commit (string-append "v" version))))
(sha256
- (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
+ (base32 "0hagizc636wfcfmdl0f4bghprjnz1dba2kvkwh2ysj485n8lmjh4"))
(file-name (git-file-name name version))))
(native-inputs
`(("python" ,python-wrapper)))
@@ -132,12 +132,12 @@
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader.git")
+ (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
+ "03xjkfb98paya5h18qsqdf3gqp063iblgbgahcfji9q91i0b327z"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Tests need stub loader setup.
(native-search-paths