summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-04-06 16:49:21 +0000
committerGuix Patches Tester <>2024-04-17 14:26:51 +0200
commit276265477e87cc721448cf369030921c040e35bb (patch)
tree9bfb11738cf8cb7b96ce68722e6a8097a30db802
parent23cf59c751b7d5bebc35a91c8276329bf7b0a2cb (diff)
downloadguix-patches-276265477e87cc721448cf369030921c040e35bb.tar
guix-patches-276265477e87cc721448cf369030921c040e35bb.tar.gz
gnu: Add materialx.
* gnu/packages/graphics.scm (materialx): New variable. Change-Id: I62c6a1675114611f23287068148171a44fa30a42
-rw-r--r--gnu/packages/graphics.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 6bde47d531..d45b675a19 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1366,6 +1366,41 @@ visual effects work for film.")
(home-page "https://www.openimageio.org")
(license license:bsd-3)))
+(define-public materialx
+ (package
+ (name "materialx")
+ (version "1.38.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AcademySoftwareFoundation/MaterialX")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "190xkg1q1sr9d95rq8rim6cxzlg2safki9i9zjsjw9wwv2bl95wr"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke
+ "ctest" "-E"
+ "MaterialXTest_Render_GLSL_TestSuite")))))))
+ (inputs
+ (list libglvnd libx11 libxt))
+ (home-page "https://materialx.org/")
+ (synopsis
+ "Standard for the exchange of rich material and look-development content")
+ (description "MaterialX is an open standard for representing rich material
+and look-development content in computer graphics, enabling its
+platform-independent description and exchange across applications and
+renderers.")
+ (license license:asl2.0)))
+
(define-public openscenegraph
(package
(name "openscenegraph")