summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordan <i@dan.games>2024-03-28 11:54:52 +0800
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-01 01:10:47 -0400
commit1f69c19b4c4d4b770dfb69d3bf3a37e02fae8c97 (patch)
tree913359e1ca4ff9e0ff4d0c0bdea2cf68a5c3aeaa
parent74f849235ab453522381136ebd3b9f5f2b84f32f (diff)
downloadguix-patches-1f69c19b4c4d4b770dfb69d3bf3a37e02fae8c97.tar
guix-patches-1f69c19b4c4d4b770dfb69d3bf3a37e02fae8c97.tar.gz
gnu: magic-enum: Update to 0.9.5.
* gnu/packages/cpp.scm (magic-enum): Update to 0.9.5. Change-Id: I8306d7ef69276e33f7daada895165a88bfc938ad Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--gnu/packages/cpp.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index acbe3e4836..cfff141dcc 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1795,7 +1796,7 @@ queues header library based on circular buffer with @code{std::atomic}.")
(define-public magic-enum
(package
(name "magic-enum")
- (version "0.7.3")
+ (version "0.9.5")
(home-page "https://github.com/Neargye/magic_enum")
(source (origin
(method git-fetch)
@@ -1805,7 +1806,7 @@ queues header library based on circular buffer with @code{std::atomic}.")
(file-name (git-file-name name version))
(sha256
(base32
- "1x47radgsifgz3vn2561mlvf4cq46ii33cpyqf01znm56iirwq89"))))
+ "14ys5sn2v1mai8bclvi81cp65g6jblqpdsi94639hphca5v8gka3"))))
(build-system cmake-build-system)
(synopsis "C++17 header only library for compile time reflection of enums")
(description "Magic Enum offers static reflection of enums, with