summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordan <i@dan.games>2024-03-28 11:54:51 +0800
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-01 01:06:45 -0400
commit74f849235ab453522381136ebd3b9f5f2b84f32f (patch)
treef39e203ecc12c5ee750fff4ea5c6cb5560c9fb19
parent083c9c010903ad42736e1fd000546042fbfafb1c (diff)
downloadguix-patches-74f849235ab453522381136ebd3b9f5f2b84f32f.tar
guix-patches-74f849235ab453522381136ebd3b9f5f2b84f32f.tar.gz
gnu: vulkan-tools: Update to 1.3.280.0.
* gnu/packages/vulkan.scm (vulkan-tools): Update to 1.3.280.0. [source]: Add snippet to disable a test. [arguments]: Remove GLSLANG_INSTALL_DIR from configure-flags. Enable tests. Replace the check phase [native-inputs]: Add googletest. Change-Id: Iadf98fc95d0d70c3780159992ebc2fdff6a2d108 Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--gnu/packages/vulkan.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 1bd7339277..baa2427551 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -327,26 +327,34 @@ and the ICD.")
(define-public vulkan-tools
(package
(name "vulkan-tools")
- (version %vulkan-sdk-version)
+ (version "1.3.280.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/KhronosGroup/Vulkan-Tools")
- (commit version)))
+ (commit (string-append "vulkan-sdk-" version))))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet #~(substitute* "tests/icd/mock_icd_tests.cpp"
+ ;; Disable driver info test since it relies on git branch info
+ (("ASSERT_EQ\\(std::string\\(driver_properties\\.driverInfo\\)")
+ "// ASSERT_EQ(std::string(driver_properties.driverInfo)")))
(sha256
(base32
- "0jzwjfx4c7y15wkwfhhc64rzljpi47bxrm5jw5blfsqjh8zsd27a"))))
+ "0w0m04vscr4a6vr682g3mn7mfni740cmai9ylzlgfdggb77y58xz"))))
(build-system cmake-build-system)
(inputs
(list glslang libxrandr vulkan-loader wayland wayland-protocols))
(native-inputs
- (list pkg-config python vulkan-headers))
+ (list googletest pkg-config python volk vulkan-headers))
(arguments
- `(#:tests? #f ;no tests
- #:configure-flags (list (string-append "-DGLSLANG_INSTALL_DIR="
- (assoc-ref %build-inputs "glslang")))))
+ `(#:configure-flags (list "-DBUILD_TESTS=ON")
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./tests/vulkan_tools_tests")))))))
(home-page
"https://github.com/KhronosGroup/Vulkan-Tools")
(synopsis "Tools and utilities for Vulkan")