summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-04 16:28:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-04 16:28:57 +0300
commit31411b4f3250df2d2e04480f289b199ab063cadf (patch)
treebb20fe7c025c05fba1471ac46249c28faeb0cfe2
parent8ecd6af8f6d9a41651213a121e11d49a1ec40e7a (diff)
downloadguix-patches-31411b4f3250df2d2e04480f289b199ab063cadf.tar
guix-patches-31411b4f3250df2d2e04480f289b199ab063cadf.tar.gz
gnu: mesa: Don't skip extra tests on aarch64-linux.
* gnu/packages/gl.scm (mesa)[arguments]: In the 'disable-failing-test phase remove the test skipped only on aarch64-linux. Change-Id: I2f6d978775887270b6374faaa48318565e393767
-rw-r--r--gnu/packages/gl.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e03c73bc79..189a0345a6 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017-2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2019, 2021, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -468,11 +468,6 @@ svga,swrast,virgl,zink")))
;; https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091).
`((substitute* "src/util/meson.build"
((".*'tests/u_debug_stack_test.cpp',.*") ""))))
- ("aarch64-linux"
- ;; The ir3_disasm test segfaults.
- ;; The simplest way to skip it is to run a different test instead.
- `((substitute* "src/freedreno/ir3/meson.build"
- (("disasm\\.c'") "delay.c',\n link_args: ld_args_build_id"))))
("armhf-linux"
;; Disable some of the llvmpipe tests.
`((substitute* "src/gallium/drivers/llvmpipe/meson.build"