summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-07 09:22:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-07 09:22:23 +0300
commit1b86dfa34dfa8e7cf145c71069bfb426e4706e4b (patch)
tree580be58be648161c10a2d5ddaa50a1a80b26b841
parent764e5afbea5784813a001ec1ee5dbc1eed558848 (diff)
downloadguix-patches-1b86dfa34dfa8e7cf145c71069bfb426e4706e4b.tar
guix-patches-1b86dfa34dfa8e7cf145c71069bfb426e4706e4b.tar.gz
gnu: mesa: Adjust skipped tests on powerpc-linux.
* gnu/packages/gl.scm (mesa)[arguments]: In the 'disable-failing-test phase enable another test when building for powerpc-linux. Change-Id: Ib043b2ea77dc145b3b067496ed45662ad635dc72
-rw-r--r--gnu/packages/gl.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index a2018222d5..87149ebb5f 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -451,14 +451,12 @@ svga,swrast,virgl,zink")))
;; There are some tests which fail specifically on powerpc.
`((substitute* '(;; LLVM ERROR: Relocation type not implemented yet!
"src/gallium/drivers/llvmpipe/meson.build"
- ;; This is probably a big-endian test failure.
"src/gallium/targets/osmesa/meson.build")
(("if with_tests") "if not with_tests"))
- ;; This test times out and receives SIGTERM.
+ ;; This is probably a big-endian test failure.
(substitute* "src/amd/common/meson.build"
- (("and not with_platform_windows") "and with_platform_windows"))
- (substitute* "src/compiler/nir/meson.build"
- ((".*loop_unroll_tests.*") ""))))
+ (("and not with_platform_windows")
+ "and with_platform_windows"))))
("i686-linux"
;; This test is known to fail on i686 (see:
;; https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091).