summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-15 09:26:58 +0100
committerChristopher Baines <mail@cbaines.net>2024-05-19 12:49:25 +0100
commita47cab5d286f81278af6e26a359f6429fd085e10 (patch)
treea0fc025992dabaeab2070908b3882e4b63c09ace
parente9b25a6c6c626a560d28a1f732e6e5d362d584a4 (diff)
downloadguix-patches-a47cab5d286f81278af6e26a359f6429fd085e10.tar
guix-patches-a47cab5d286f81278af6e26a359f6429fd085e10.tar.gz
gnu: ruby-ruby-memcheck: Use non-interactive valgrind.
Use valgrind rather than valgrind/interactive, as this doesn't have gdb as an input, which makes it easier to update gdb. * gnu/packages/ruby.scm (ruby-ruby-memcheck)[inputs]: Use valgrind. Change-Id: Icfcee2c27fc41e68e1a34b38c043ece188cc56af
-rw-r--r--gnu/packages/ruby.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9449e09917..5c1e666bb0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10114,7 +10114,7 @@ Profiling multiple threads simultaneously is supported.
(("%x\\(git ls-files -z)")
"`git ls-files -z`")))))))
(native-inputs (list ruby-rake-compiler ruby-rspec))
- (inputs (list valgrind/interactive))
+ (inputs (list valgrind))
(propagated-inputs (list ruby-nokogiri))
(synopsis "Valgrind memcheck tool for Ruby")
(description "The @code{ruby_memcheck} gem provides a sane way to use