summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-09 00:50:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-09 00:50:29 +0100
commit2463e9f1fe10a1d7e02dff76f200da69cd3f24d1 (patch)
treed110a22447b4ff2083bde1a33c3d45bbf9b0ddac
parent9e14a7b4d20c98b78789975d0232f8f0524b9d8a (diff)
downloadguix-patches-2463e9f1fe10a1d7e02dff76f200da69cd3f24d1.tar
guix-patches-2463e9f1fe10a1d7e02dff76f200da69cd3f24d1.tar.gz
gnu: Remove java-ecj-3.
* gnu/packages/java.scm (java-ecj-3): Remove variable.
-rw-r--r--gnu/packages/java.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 775840d026..a2650b1826 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2204,42 +2204,6 @@ debugging, etc.")
(native-inputs
(list javacc-4))))
-;; This is the last 3.x release of ECJ
-(define-public java-ecj-3
- (package
- (name "java-ecj")
- (version "3.8.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://archive.eclipse.org/eclipse/"
- "downloads/drops/R-" version
- "-201301310800/ecjsrc-" version ".jar"))
- (sha256
- (base32
- "01mdj14jw11g1jfnki4fi8229p0c6zzckd38zqy2w4m3cjcvsx04"))))
- (build-system ant-build-system)
- (arguments
- `(#:tests? #f ; none included
- #:jdk ,icedtea-7 ; doesn't build with JDK8+
- #:make-flags (list "-f" "src/build.xml")
- #:build-target "build"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-manifest
- (lambda _
- ;; Record the main class to make ecj executable.
- (with-atomic-file-replacement "src/META-INF/MANIFEST.MF"
- (lambda (in out)
- (display "Manifest-Version: 1.0
-Main-Class: org.eclipse.jdt.internal.compiler.batch.Main\n"
- out)))
- #t))
- (replace 'install (install-jars ".")))))
- (home-page "https://eclipse.org")
- (synopsis "Eclipse Java development tools core batch compiler")
- (description "This package provides the Eclipse Java core batch compiler.")
- (license license:epl1.0)))
-
(define-public java-ecj
(package
(name "java-ecj")