summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-02 21:05:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:09 +0100
commitfc92d33932cd3b581c9085c03751ae4f01ade04b (patch)
tree4d9cba209c1f4275d6a57e583b5b9981382499fb
parent7d4d0512a06e77c06e29f89e573e3aa8701531d4 (diff)
downloadguix-patches-fc92d33932cd3b581c9085c03751ae4f01ade04b.tar
guix-patches-fc92d33932cd3b581c9085c03751ae4f01ade04b.tar.gz
gnu: Add python-pysiaf.
* gnu/packages/astronomy.scm (python-pysiaf): New variable. Change-Id: Ide732d666bccad885ed3e8c78d62df7e74524b9a
-rw-r--r--gnu/packages/astronomy.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b014ac4653..a558e0bbac 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4209,6 +4209,45 @@ Features:
@end itemize")
(license license:expat)))
+(define-public python-pysiaf
+ (package
+ (name "python-pysiaf")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pysiaf" version))
+ (sha256
+ (base32 "08wb98k9k4f04455da5ns9rif8pl9r3ih537w1yj393hkjjiyzfz"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-n" "auto"
+ ;; Disable 2 failing tests, see
+ ;; <https://github.com/spacetelescope/pysiaf/issues/338>
+ "-k" (string-append "not test_write_jwst_siaf_xlsx"
+ " and not test_write_jwst_siaf_xml" ))))
+ (propagated-inputs
+ (list python-astropy
+ python-lxml
+ python-matplotlib
+ python-numpy
+ python-numpydoc
+ python-openpyxl
+ python-requests
+ python-scipy))
+ (native-inputs
+ (list python-pytest python-pytest-xdist))
+ (home-page "https://pysiaf.readthedocs.io/")
+ (synopsis "Handling SIAF for space telescopes")
+ (description
+ "@code{pysiaf} is a python package to access, interpret, maintain, and
+generate @acronym{Handling of Science Instrument Aperture Files, SIAF}, in
+particular for JWST. Tools for applying the frame transformations, plotting,
+comparison, and validation are provided.")
+ (license license:bsd-3)))
+
(define-public python-pysynphot
;; XXX: 2.0.0 was released in 2021 there are a lot of changes since that
;; time and it failed to build with python-astropy 6.0.0, use the latest