summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-17 15:24:04 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 21:31:52 +0100
commitee86a504e9223b1ef861d830ecf3aaf03cc1364d (patch)
treea58cd71ba823cf718ac7a9a1db5de46473d3685a
parent3597c736588c45efde3c22d533ea8774c3fdd235 (diff)
downloadguix-patches-ee86a504e9223b1ef861d830ecf3aaf03cc1364d.tar
guix-patches-ee86a504e9223b1ef861d830ecf3aaf03cc1364d.tar.gz
gnu: augeas: Update to 1.14.1.
* gnu/packages/augeas.scm (augeas): Update to 1.14.1. [source]: Use tarballs from GitHub. [inputs]: Change to "native-inputs". Add readline. Change-Id: I9ca46b8a50d11c75ff6d816f2f15e1f005877244 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/augeas.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/augeas.scm b/gnu/packages/augeas.scm
index 2fd933604c..f643b1573e 100644
--- a/gnu/packages/augeas.scm
+++ b/gnu/packages/augeas.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
(define-module (gnu packages augeas)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
@@ -33,22 +35,26 @@
(define-public augeas
(package
(name "augeas")
- (version "1.12.0")
+ (version "1.14.1")
(source (origin
+ ;; XXX: Project release has moved to GitHub which has
+ ;; pre-generated "configure" script that allows to simplify
+ ;; the package definition. Try to completely build from
+ ;; source, glibc comes as git submodule.
(method url-fetch)
- (uri (string-append "http://download.augeas.net/augeas-"
- version ".tar.gz"))
+ (uri
+ (string-append
+ "https://github.com/hercules-team/augeas/releases/download/"
+ "release-" version
+ "/augeas-" version ".tar.gz"))
(sha256
(base32
- "11ybhb13wkkilsn7b416a1dn61m1xrq0lbdpkhp5w61jrk4l469j"))))
+ "1zzdp5bwnszza5q6cjw66hkicay8b49n5pda7cbcgfg4hbbzv2rn"))))
(build-system gnu-build-system)
- ;; Marked as "required" in augeas.pc.
(propagated-inputs
(list libxml2))
- (inputs
- (list readline))
(native-inputs
- (list pkg-config))
+ (list readline pkg-config))
(home-page "https://augeas.net")
(synopsis "Edit configuration files programmatically")
(description