summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraecepoglu <aecepoglu@fastmail.fm>2024-04-30 01:50:32 +0100
committerGuix Patches Tester <>2024-04-30 03:54:06 +0200
commit0247e955f615f5a0ed7246b4f50a67a9d86cb730 (patch)
tree004d739ab23d397538a353487c279b708249a39f
parentdf56bec07691782ca9f31cc93250f7addd4ac13c (diff)
downloadguix-patches-0247e955f615f5a0ed7246b4f50a67a9d86cb730.tar
guix-patches-0247e955f615f5a0ed7246b4f50a67a9d86cb730.tar.gz
gnu: bqn: Update bqn-sources.
* gnu/packages/bqn.scm (bqn-sources): Update bqn-sources version. Change-Id: Ia17dfbc3d6d73fdf3203c99a229eccc6634eca2a
-rw-r--r--gnu/packages/bqn.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index 4252f9508e..e6cc2aeef1 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -135,17 +135,16 @@ the same author.")
(define bqn-sources
;; Aside from dbqn above, the main bqn repository is used by other
- ;; implementations as a "known good" set of sources. CBQN uses dbqn to
- ;; generate an intermediate bytecode for its own compilation.
- (let ((commit "71ce36141aaacfa714edca2e408ca522a3bc5554"))
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mlochbaum/BQN")
- (commit commit)))
- (file-name (git-file-name "bqn-sources" commit))
- (sha256
- (base32 "060a3r5m7hynzxj4iz1av2kj5jf8w3j8yswzzx9wkx31rdrsiv2c")))))
+ ;; implementations as a "known good" set of sources.
+ ;; CBQN initially uses dbqn to bootstrap itself.
+ ;; We use cbqn-bootstrap to build BQN for the end-users
+ (let ((commit "6f651be3e09f0628c7d47ddb7ce819a1755529ca"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/mlochbaum/BQN")
+ (commit commit)))
+ (file-name (git-file-name "bqn-sources" commit))
+ (sha256 (base32 "0jhrazwp4s1a0pzrzyxi7szpchp4avqsvpmslfsgk3c88wf57q6b")))))
(define cbqn-bootstrap
(let* ((revision "2")