summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-07 09:49:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-07 09:49:30 +0300
commit1e58b81da9958b454cd10c8aff73829f26d22392 (patch)
tree15c4f47d9684e45a8d7acb6d1b1df7f9528fea34
parent1fed3f98774d461f0d28d3fff73c6c924db81ef7 (diff)
downloadguix-patches-1e58b81da9958b454cd10c8aff73829f26d22392.tar
guix-patches-1e58b81da9958b454cd10c8aff73829f26d22392.tar.gz
gnu: glslang: Give more information on test failures.
* gnu/packages/vulkan.scm (glslang)[arguments]: Adjust the 'check phase to run the tests in parallel, rerun tests which fail and to provide information when a test fails. Change-Id: I13962bb503a20338901cdd878d356e1bcce7f2eb
-rw-r--r--gnu/packages/vulkan.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 997e653010..4a1d5914ce 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -207,9 +207,14 @@ translation between LLVM IR and SPIR-V.")
'()))
#:phases (modify-phases %standard-phases
(replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(when tests?
- (invoke "ctest")))))))
+ (invoke "ctest"
+ "-j" (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")
+ "--rerun-failed"
+ "--output-on-failure")))))))
(inputs (list spirv-tools))
(native-inputs
(list pkg-config python))