summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-04-03 17:26:40 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-03 17:26:40 -0400
commit4cb7978a19637a7cb73e33a5a2d0dcb5e0c936d9 (patch)
treecde57897696216d9f6d918802358d6c6f26226a9
parent31b981bdcd910527c32e0ad89276be84cb483551 (diff)
downloadguix-patches-4cb7978a19637a7cb73e33a5a2d0dcb5e0c936d9.tar
guix-patches-4cb7978a19637a7cb73e33a5a2d0dcb5e0c936d9.tar.gz
gnu: godot: Update to 4.2.1.
The previous version failed to build after an update to glslang. Godot looks for an include, Types.h, which is no longer included in the built glslang. Use the included glslang (which will match the included vulkan, too) for now. * gnu/packages/game-development.scm (godot): Update to 4.2.1. [source]: In snippet add (preserve) amd-fsr2, clipper2, glslang (for now), and libktx. [arguments]: Comment out "builtin_glslang=no" in #:scons-flags (for now). Change-Id: I8f6c20e3796ea96f2e6a6a167063f10a667bd4c3
-rw-r--r--gnu/packages/game-development.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ae313a8edf..c65ab74832 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2095,7 +2095,7 @@ scripted in a Python-like language.")
(define-public godot
(package
(name "godot")
- (version "4.1.3")
+ (version "4.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2104,7 +2104,7 @@ scripted in a Python-like language.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mwwzf77ixkalciqakn6q42g9sl2570didfll406sfs42wz534ng"))
+ "0d5y678986lx4a4xjkxs5glh2dckp8wwl3r3mw72inq7gvaa18s3"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -2117,19 +2117,28 @@ scripted in a Python-like language.")
(let* ((preserved-files
'("README.md"
"amd-fsr"
+ "amd-fsr2"
"assimp"
"astcenc"
"basis_universal"
;; Godot needs ca-certificates.crt, but that is
;; not available in build environment
"certs"
+ "clipper2"
"cvtt"
"linuxbsd_headers"
"etc2comp"
"etcpak"
"fonts"
"glad"
+ ;; TODO: Remove once Godot once again builds
+ ;; with our glslang package, or with a
+ ;; workaround. Currently it looks for a Types.h
+ ;; which is no longer in the glslang output
+ ;; after the most recent update.
+ "glslang"
"jpeg-compressor"
+ "libktx"
"libsimplewebm"
"meshoptimizer"
"minimp3"
@@ -2170,7 +2179,9 @@ scripted in a Python-like language.")
"builtin_embree=no"
"builtin_enet=no"
"builtin_freetype=no"
- "builtin_glslang=no"
+ ;; TODO: Uncomment this option when the todo for
+ ;; glslang in the snippet is resolved.
+ ;; "builtin_glslang=no"
"builtin_graphite=no"
"builtin_harfbuzz=no"
"builtin_icu4c=no"