summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-15 11:13:23 +0300
committerGuillaume Le Vaillant <glv@posteo.net>2024-05-15 13:49:01 +0200
commitd8d0fdd25ce3479f7ba45e1800241196b6828284 (patch)
treeef8ba061e7aa9fcbe495b74c4d87693e07eb8adc
parent5c90e7d6d9a5107856bc90ff7e51580a27b0098a (diff)
downloadguix-patches-d8d0fdd25ce3479f7ba45e1800241196b6828284.tar
guix-patches-d8d0fdd25ce3479f7ba45e1800241196b6828284.tar.gz
gnu: python-pivy: Fix build.
"python-pivy" build fails when "soqt" is in the inputs (see <https://bugs.gentoo.org/920482>.) * gnu/packages/python-xyz.scm (python-pivy): Fix build. [inputs]: Remove "soqt". [arguments]: Use gexps. Change-Id: If332ccd42b3a373e7b4118f3bcbc3646e8b59d41 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index da70779df5..a9a1f5f416 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,7 +121,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
-;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
@@ -32933,20 +32933,20 @@ used to retry a function a given number of times.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
+ (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
(build-system python-build-system)
(arguments
- `(;; The test suite fails due to an import cycle between 'pivy' and '_coin'
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
+ (list
+ ;; The test suite fails due to an import cycle between 'pivy' and '_coin'
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
(add-after 'unpack 'patch-cmake-include-dirs
- (lambda _
- ;; Patch buildsystem to respect Coin3D include directory
- (substitute* "CMakeLists.txt"
- (("\\$\\{SoQt_INCLUDE_DIRS}")
- "${Coin_INCLUDE_DIR};${SoQt_INCLUDE_DIRS}"))
- #t)))))
+ (lambda _
+ ;; Patch buildsystem to respect Coin3D include directory
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{SoQt_INCLUDE_DIRS}")
+ "${Coin_INCLUDE_DIR};${SoQt_INCLUDE_DIRS}")))))))
(native-inputs
(list cmake swig))
(inputs
@@ -32954,7 +32954,6 @@ used to retry a function a given number of times.")
qtbase-5
libxi
libice
- soqt
glew
coin3d))
(home-page "https://github.com/coin3d/pivy")