summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-05-15 14:51:38 +0200
committerAndreas Enge <andreas@enge.fr>2024-05-15 15:06:49 +0200
commit8e5579f37c4de33b4ed160642577fe5a83ec5910 (patch)
tree6ee3bcce56026341a57c68b05971b52ae01c54c3
parentfcf6d663e33eecd7678663c4bc44adf7c0aabce2 (diff)
downloadguix-patches-8e5579f37c4de33b4ed160642577fe5a83ec5910.tar
guix-patches-8e5579f37c4de33b4ed160642577fe5a83ec5910.tar.gz
gnu: minizinc: Use gexps.
* gnu/packages/maths.scm (minizinc): Use gexps. Change-Id: I60a0d56b6d6ba33d96ca13b58355b5c213b0f6d2
-rw-r--r--gnu/packages/maths.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3884506c5b..1feabe5f1c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4154,17 +4154,18 @@ book.")
#t))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no ‘check’ target
- #:modules ((guix build cmake-build-system)
- (guix build utils)
- (srfi srfi-1))
+ (list
+ #:tests? #f ; no ‘check’ target
+ #:modules '((guix build cmake-build-system)
+ (guix build utils)
+ (srfi srfi-1))
#:phases
- (modify-phases %standard-phases
+ #~(modify-phases %standard-phases
(add-after 'install 'install-solver-configs
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((chuffed (assoc-ref inputs "chuffed"))
- (gecode (assoc-ref inputs "gecode"))
- (pkgdatadir (string-append (assoc-ref outputs "out")
+ (lambda _
+ (let ((chuffed #$(this-package-input "chuffed"))
+ (gecode #$(this-package-input "gecode"))
+ (pkgdatadir (string-append #$output
"/share/minizinc")))
(call-with-output-file (string-append pkgdatadir
"/Preferences.json")