summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-02-02 11:49:37 +0800
committerLeo Famulari <leo@famulari.name>2023-02-09 14:27:27 +0100
commit1cc0f0efd4d5bbe2e7ec429acaab892a618e8a66 (patch)
treebf0c29f1e64f62f72d294f7ef5e0fa53aeba1e2d
parent9c3a2abc9a27482bcbebd67fc2b468fbc2c81234 (diff)
downloadguix-patches-1cc0f0efd4d5bbe2e7ec429acaab892a618e8a66.tar
guix-patches-1cc0f0efd4d5bbe2e7ec429acaab892a618e8a66.tar.gz
gnu: Add Go 1.20.
* gnu/packages/golang.scm (go-1.20): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cf15b81fe7..d4f79eb50b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -887,6 +888,27 @@ in the style of communicating sequential processes (@dfn{CSP}).")
'("CONTRIBUTING.md" "PATENTS" "README.md"
"SECURITY.md"))))))))))
+(define-public go-1.20
+ (package
+ (inherit go-1.19)
+ (name "go")
+ (version "1.20")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/go")
+ (commit (string-append "go" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a7wjzv14kaqg5l7ambv5zj4rj7sgah9yhcg6k6da6ygm6bs4dv3"))))
+ (native-inputs
+ ;; Go 1.20 and later requires Go 1.17 as the bootstrap toolchain.
+ ;; See 'src/cmd/dist/notgo117.go' in the source code distribution,
+ ;; as well as the upstream discussion of this topic:
+ ;; https://go.dev/issue/44505
+ (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17)))))
+
(define-public go go-1.17)
(define make-go-std