summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-04 15:22:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-04 15:22:03 +0200
commitc0f62879744e737c5ab1dfebc69a769a2152b652 (patch)
tree252b1e196492d0a116a7a1d3e34d6e30a4dd6929
parentc3a2d354e3091a94819fb2dccd515b5eaa3048ac (diff)
downloadguix-patches-c0f62879744e737c5ab1dfebc69a769a2152b652.tar
guix-patches-c0f62879744e737c5ab1dfebc69a769a2152b652.tar.gz
gnu: nauty: Update package style.
* gnu/packages/maths.scm (nauty)[arguments]: Use G-expressions. Remove trailing #T.
-rw-r--r--gnu/packages/maths.scm76
1 files changed, 37 insertions, 39 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a8a42579c7..9869fa9283 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7042,46 +7042,44 @@ management via the GIMPS project's Primenet server.")
(build-system gnu-build-system)
(outputs '("out" "lib"))
(arguments
- `(#:test-target "checks"
- #:configure-flags '("--enable-generic") ;prevent -march-native
- #:phases
- (modify-phases %standard-phases
- ;; Default make target does not build all available
- ;; executables. Create them now.
- (add-after 'build 'build-extra-programs
- (lambda _
- (for-each (lambda (target) (invoke "make" target))
- '("blisstog" "bliss2dre" "checks6" "sumlines"))
- #t))
- ;; Upstream does not provide any install target.
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib-output (assoc-ref outputs "lib"))
- (bin (string-append out "/bin"))
- (doc (string-append out "/share/doc/nauty/"))
- (include (string-append lib-output "/include/nauty"))
- (lib (string-append lib-output "/lib/nauty")))
- (for-each (lambda (f) (install-file f bin))
- '("addedgeg" "amtog" "assembleg" "biplabg" "blisstog"
- "bliss2dre" "catg" "checks6" "complg" "converseg"
- "copyg" "countg" "cubhamg" "deledgeg" "delptg"
- "directg" "dreadnaut" "dretodot" "dretog" "genbg"
- "genbgL" "geng" "genquarticg" "genrang" "genspecialg"
- "gentourng" "gentreeg" "hamheuristic" "labelg"
- "linegraphg" "listg" "multig" "newedgeg" "pickg"
- "planarg" "ranlabg" "shortg" "showg" "subdivideg"
- "sumlines" "twohamg" "underlyingg" "vcolg"
- "watercluster2" "NRswitchg"))
- (for-each (lambda (f) (install-file f include))
- (find-files "." "\\.h$"))
- (for-each (lambda (f) (install-file f lib))
- (find-files "." "\\.a$"))
- (for-each (lambda (f) (install-file f doc))
- (append '("formats.txt" "README" "schreier.txt")
- (find-files "." "\\.pdf$")))))))))
+ (list
+ #:test-target "checks"
+ #:configure-flags #~(list "--enable-generic") ;prevent -march-native
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Default make target does not build all available
+ ;; executables. Create them now.
+ (add-after 'build 'build-extra-programs
+ (lambda _
+ (for-each (lambda (target) (invoke "make" target))
+ '("blisstog" "bliss2dre" "checks6" "sumlines"))))
+ ;; Upstream does not provide any install target.
+ (replace 'install
+ (lambda _
+ (let* ((bin (string-append #$output "/bin"))
+ (doc (string-append #$output "/share/doc/nauty/"))
+ (include (string-append #$output:lib "/include/nauty"))
+ (lib (string-append #$output:lib "/lib/nauty")))
+ (for-each (lambda (f) (install-file f bin))
+ '("addedgeg" "amtog" "assembleg" "biplabg" "blisstog"
+ "bliss2dre" "catg" "checks6" "complg" "converseg"
+ "copyg" "countg" "cubhamg" "deledgeg" "delptg"
+ "directg" "dreadnaut" "dretodot" "dretog" "genbg"
+ "genbgL" "geng" "genquarticg" "genrang" "genspecialg"
+ "gentourng" "gentreeg" "hamheuristic" "labelg"
+ "linegraphg" "listg" "multig" "newedgeg" "pickg"
+ "planarg" "ranlabg" "shortg" "showg" "subdivideg"
+ "sumlines" "twohamg" "underlyingg" "vcolg"
+ "watercluster2" "NRswitchg"))
+ (for-each (lambda (f) (install-file f include))
+ (find-files "." "\\.h$"))
+ (for-each (lambda (f) (install-file f lib))
+ (find-files "." "\\.a$"))
+ (for-each (lambda (f) (install-file f doc))
+ (append '("formats.txt" "README" "schreier.txt")
+ (find-files "." "\\.pdf$")))))))))
(inputs
- (list gmp)) ;for sumlines
+ (list gmp)) ;for sumlines
(home-page "https://pallini.di.uniroma1.it/")
(synopsis "Library for graph automorphisms")
(description "@code{nauty} (No AUTomorphisms, Yes?) is a set of