summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-13 01:01:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:22 -0400
commit7cab14c3363ae8ccdcec5b67bdad645eabd6b792 (patch)
tree8932bfff083b7c790aa0c1e6f38516f8e6150e5d
parent1c8264d62e16f404786d9b526511cea29138ab9f (diff)
downloadguix-patches-7cab14c3363ae8ccdcec5b67bdad645eabd6b792.tar
guix-patches-7cab14c3363ae8ccdcec5b67bdad645eabd6b792.tar.gz
gnu: python-nbformat: Update to 5.3.0.
* gnu/packages/python-xyz.scm (python-nbformat): Update to 5.3.0. [source]: Adjust git URL. [native-inputs]: Move python-fastjsonschema to... [propagated-inputs]: ... here. Remove python-ipython-genutils.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd8ae0e5e5..e1076b7190 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12816,16 +12816,16 @@ drafts 04, 06 and 07.")
(define-public python-nbformat
(package
(name "python-nbformat")
- (version "5.1.3")
+ (version "5.3.0")
;; The PyPi release tarball lacks some test cases and test data.
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/jupyter/nbformat.git")
+ (url "https://github.com/jupyter/nbformat")
(commit version)))
(sha256
(base32
- "033v16cfmxzh3jn5phnil4p3silr49iwh9wiigzhv0crc6sanvwz"))
+ "114c5c6cvpxhxj8zrw74351gcfzyzjh1jq3py4xf8wk9rahfay9z"))
(file-name (git-file-name name version))))
(build-system python-build-system)
(arguments
@@ -12836,13 +12836,10 @@ drafts 04, 06 and 07.")
(when tests?
(invoke "pytest" "-vv")))))))
(propagated-inputs
- (list python-ipython-genutils python-jsonschema python-jupyter-core
+ (list python-fastjsonschema python-jsonschema python-jupyter-core
python-traitlets))
(native-inputs
(list python-pytest
- python-fastjsonschema ; This is only active
- ; when setting NBFORMAT_VALIDATOR="fastjsonschema", so include it for
- ; testing only.
python-testpath))
(home-page "https://jupyter.org")
(synopsis "Jupyter Notebook format")