summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-04 15:32:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-04 15:32:34 +0200
commit30f8183b9a86f53e8e7c86bc0517442f5689c8d0 (patch)
tree73be7eb53e27112fa2fbb6ff8ada2b88c85b9133
parente5b33491281658235cc7af765a94e459fa3e2942 (diff)
downloadguix-patches-30f8183b9a86f53e8e7c86bc0517442f5689c8d0.tar
guix-patches-30f8183b9a86f53e8e7c86bc0517442f5689c8d0.tar.gz
gnu: emacs-rg: Update to 2.2.1.
* gnu/packages/emacs-xyz.scm (emacs-rg): Update to 2.2.1.
-rw-r--r--gnu/packages/emacs-xyz.scm62
1 files changed, 30 insertions, 32 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 72b2d09130..79324ab3a3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5046,40 +5046,38 @@ result.")
(license license:gpl2+)))
(define-public emacs-rg
- (let ((commit "444a8ccfea0b38452a0bc4c390a8ee01cfe30017")
- (revision "0"))
- (package
- (name "emacs-rg")
- (version (git-version "2.2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dajva/rg.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1nxzplpk5cf6hhr2v85bmg68i6am96shi2zq7m83fs96bilhwsp5"))))
- (build-system emacs-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-rg-path
- ;; Remove the path to ripgrep so that it works on remote systems.
- (lambda _
- (let ((file "rg.el"))
- (chmod file #o644)
- (emacs-substitute-sexps file
- ("(defcustom rg-executable" "rg"))))))))
- (propagated-inputs
- (list emacs-s emacs-transient emacs-wgrep ripgrep))
- (home-page "https://rgel.readthedocs.io/en/latest/")
- (synopsis "Search tool based on @code{ripgrep}")
- (description
- "@code{rg} is an Emacs search package based on the @code{ripgrep} command
+ (package
+ (name "emacs-rg")
+ (version "2.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dajva/rg.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nxzplpk5cf6hhr2v85bmg68i6am96shi2zq7m83fs96bilhwsp5"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-rg-path
+ ;; Remove the path to ripgrep so that it works on remote systems.
+ (lambda _
+ (let ((file "rg.el"))
+ (chmod file #o644)
+ (emacs-substitute-sexps file
+ ("(defcustom rg-executable" "rg"))))))))
+ (propagated-inputs
+ (list emacs-s emacs-transient emacs-wgrep ripgrep))
+ (home-page "https://rgel.readthedocs.io/en/latest/")
+ (synopsis "Search tool based on @code{ripgrep}")
+ (description
+ "@code{rg} is an Emacs search package based on the @code{ripgrep} command
line tool. It allows one to interactively search based on the editing context
then refine or modify the search results.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-inf-ruby
(package