summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2022-06-24 12:50:33 +0000
committerLudovic Courtès <ludo@gnu.org>2022-07-03 16:04:23 +0200
commit486251d4400fead42c3570ad63d98a10786e8dbb (patch)
tree30ca8b601130418450ff9017ea702419df3336aa
parent91a517653815eee0dac2b50543921b6c65f19378 (diff)
downloadguix-patches-486251d4400fead42c3570ad63d98a10786e8dbb.tar
guix-patches-486251d4400fead42c3570ad63d98a10786e8dbb.tar.gz
gnu: Add python-deepdish.
* gnu/packages/python-science.scm (python-deepdish): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-science.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 35daef2815..747c84d493 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1367,3 +1367,39 @@ for parameterized model creation and handling. Its features include:
Python, from the Sheffield machine learning group. GPy implements a range of
machine learning algorithms based on GPs.")
(license license:bsd-3)))
+
+(define-public python-deepdish
+ (package
+ (name "python-deepdish")
+ (version "0.3.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "deepdish" version))
+ (sha256
+ (base32
+ "1wqzwh3y0mjdyba5kfbvlamn561d3afz50zi712c7klkysz3mzva"))))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'dont-vendor-six
+ (lambda _
+ (delete-file "deepdish/six.py")
+ (substitute* "deepdish/io/hdf5io.py"
+ (("from deepdish import six") "import six"))
+ (substitute* "deepdish/io/ls.py"
+ (("from deepdish import io, six, __version__")
+ "from deepdish import io, __version__
+import six
+")))))))
+ (build-system python-build-system)
+ (native-inputs (list python-pandas))
+ (propagated-inputs (list python-numpy python-scipy python-six
+ python-tables))
+ (home-page "https://github.com/uchicago-cs/deepdish")
+ (synopsis "Python library for HDF5 file saving and loading")
+ (description
+ "Deepdish is a Python library to load and save HDF5 files.
+The primary feature of deepdish is its ability to save and load all kinds of
+data as HDF5. It can save any Python data structure, offering the same ease
+of use as pickling or @code{numpy.save}, but with the language
+interoperability offered by HDF5.")
+ (license license:bsd-3)))