summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-06-30 13:51:50 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-06-30 13:51:50 +0200
commit2c6a9ad2f0318a23e79bee96f28a56ea66aad359 (patch)
treeb6858569fe37a129220f25fd142e5a02c62e6ab5
parent49ecf1cbeedbc8a381242b692635b0b4c2576eb9 (diff)
downloadguix-patches-2c6a9ad2f0318a23e79bee96f28a56ea66aad359.tar
guix-patches-2c6a9ad2f0318a23e79bee96f28a56ea66aad359.tar.gz
gnu: sbcl: Update to 2.2.6.
* gnu/packages/lisp.scm (sbcl): Update to 2.2.6. [native-inputs]: Remove zlib. Remove labels. [inputs]: Add zstd:lib.
-rw-r--r--gnu/packages/lisp.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 3c43f8fa4c..715ba14201 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -413,14 +413,14 @@ an interpreter, a compiler, a debugger, and much more.")
(define-public sbcl
(package
(name "sbcl")
- (version "2.2.2")
+ (version "2.2.6")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
version "-source.tar.bz2"))
(sha256
- (base32 "1xjhg473ibfiplvvyg1grxrh0nqqbg72acc2pcacw7bijyzdp447"))))
+ (base32 "18044dqx37mkipnrzs7jrp0cbnwp6snb5gi06a8zn9m8iy6088ry"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(native-inputs
@@ -445,18 +445,19 @@ an interpreter, a compiler, a debugger, and much more.")
;; to make it easier to change the host compiler for various
;; architectures. Consider switching to ECL if it gets faster than CLISP
;; (maybe post 2020 release).
- `(,@(match (%current-system)
- ((or "x86_64-linux" "i686-linux")
- `(("clisp" ,clisp)))
- (_
- `(("clisp" ,clisp))))
- ("cl-asdf" ,cl-asdf)
- ("ed" ,ed)
- ("inetutils" ,inetutils) ;for hostname(1)
- ("texinfo" ,texinfo)
- ("texlive" ,(texlive-updmap.cfg (list texlive-tex-texinfo)))
- ("which" ,which)
- ("zlib" ,zlib)))
+ (list (match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ clisp)
+ (_
+ clisp))
+ cl-asdf
+ ed
+ inetutils ;for hostname(1)
+ texinfo
+ (texlive-updmap.cfg (list texlive-tex-texinfo))
+ which))
+ (inputs
+ (list (list zstd "lib")))
(arguments
`(#:modules ((guix build gnu-build-system)
(guix build utils)