summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-06-30 14:30:47 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-06-30 14:36:35 +0200
commit90defb0f14aabf5d06f129ac61d83f14b958ab12 (patch)
tree002c1254bbbeceefb5227b918cce6ff5391a2005
parente18f43f24e9f5814249c45ede89d0b6b6727082e (diff)
downloadguix-patches-90defb0f14aabf5d06f129ac61d83f14b958ab12.tar
guix-patches-90defb0f14aabf5d06f129ac61d83f14b958ab12.tar.gz
gnu: cl-lzlib: Update to 2.0-1.c8102fc.
* gnu/packages/lisp-xyz.scm (sbcl-lzlib): Update to 2.0-1.c8102fc. [inputs]: Remove labels. [arguments]: Use gexp.
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 28493f5784..7b8b5c8c56 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7135,37 +7135,36 @@ cl-plumbing libraries.")
(sbcl-package->ecl-package sbcl-cl-octet-streams))
(define-public sbcl-lzlib
- (let ((commit "cad10f5becbcfebb44b9d311a257563778803452")
- (revision "2"))
+ (let ((commit "c8102fc8c959b7c418eb60657bd6c8b875f10ba9")
+ (revision "1"))
(package
(name "sbcl-lzlib")
- (version (git-version "1.1" revision commit))
+ (version (git-version "2.0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/glv2/cl-lzlib")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-lzlib" version))
(sha256
- (base32 "09lp7li35h4jkls0448fj1sh6pjslr1w7ranbc4szjr8g0c2bdry"))))
+ (base32 "1glg1y1s1mqgypvxp0ss11cicrddri006wqwhy47lgq7mk5853zz"))))
(build-system asdf-build-system/sbcl)
(native-inputs
(list sbcl-fiveam))
(inputs
- `(("cffi" ,sbcl-cffi)
- ("cl-octet-streams" ,sbcl-cl-octet-streams)
- ("lparallel" ,sbcl-lparallel)
- ("lzlib" ,lzlib)))
+ (list lzlib
+ sbcl-cffi
+ sbcl-cl-octet-streams
+ sbcl-lparallel))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/lzlib.lisp"
- (("liblz\\.so")
- (search-input-file inputs "/lib/liblz.so")))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/lzlib.lisp"
+ (("liblz\\.so")
+ (search-input-file inputs "/lib/liblz.so"))))))))
(synopsis "Common Lisp library for lzip (de)compression")
(description
"This Common Lisp library provides functions for lzip (LZMA)