summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-30 20:02:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-30 20:59:35 +0300
commit6f2bdd4e6b71a83d9d6963d9643a5ad848c06b9d (patch)
treecac9c4f0f32a16bcde91b17d8e3d71a591a6f4ba
parent857c9ce3607b13e8e22fd5360365a74cb3ef0683 (diff)
downloadguix-patches-6f2bdd4e6b71a83d9d6963d9643a5ad848c06b9d.tar
guix-patches-6f2bdd4e6b71a83d9d6963d9643a5ad848c06b9d.tar.gz
gnu: x265: Honor make-flags.
* gnu/packages/video.scm (x265)[arguments]: Adjust custom 'build-12-bit, 'build-10-bit and 'install-more-libs phases to use standard 'make and 'install phases.
-rw-r--r--gnu/packages/video.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 55a477a8fd..4fef8a01c4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1241,7 +1241,7 @@ on the Invidious instances only as a fallback method.")
(string-append "if(TRUE)\n"
" set(X265_LATEST_TAG \"" ,version "\")\n")))))
(add-before 'configure 'build-12-bit
- (lambda* (#:key (configure-flags '()) #:allow-other-keys)
+ (lambda* (#:key (configure-flags '()) #:allow-other-keys #:rest args)
(mkdir "../build-12bit")
(with-directory-excursion "../build-12bit"
(apply invoke
@@ -1256,9 +1256,9 @@ on the Invidious instances only as a fallback method.")
(find-files "CMakeFiles/x265-shared.dir")
(find-files "CMakeFiles/x265-static.dir")))
(("libx265") "libx265_main12"))
- (invoke "make"))))
+ ((assoc-ref %standard-phases 'build)))))
(add-before 'configure 'build-10-bit
- (lambda* (#:key (configure-flags '()) #:allow-other-keys)
+ (lambda* (#:key (configure-flags '()) #:allow-other-keys #:rest args)
(mkdir "../build-10bit")
(with-directory-excursion "../build-10bit"
(apply invoke
@@ -1272,13 +1272,13 @@ on the Invidious instances only as a fallback method.")
(find-files "CMakeFiles/x265-shared.dir")
(find-files "CMakeFiles/x265-static.dir")))
(("libx265") "libx265_main10"))
- (invoke "make"))))
+ ((assoc-ref %standard-phases 'build)))))
(add-after 'install 'install-more-libs
- (lambda _
+ (lambda args
(with-directory-excursion "../build-12bit"
- (invoke "make" "install"))
+ ((assoc-ref %standard-phases 'install)))
(with-directory-excursion "../build-10bit"
- (invoke "make" "install"))))
+ ((assoc-ref %standard-phases 'install)))))
(add-before 'strip 'move-static-libs
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))