summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:49 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:27:24 +0200
commit59b340a524b2617acc846bc1fa9f54919ccd5bb0 (patch)
tree0c846e8097cefb1ab5bf8c156dca958aa364ca6a
parent789dc5680f8a52af57e5f90174c9032d3af3fb51 (diff)
downloadguix-patches-59b340a524b2617acc846bc1fa9f54919ccd5bb0.tar
guix-patches-59b340a524b2617acc846bc1fa9f54919ccd5bb0.tar.gz
gnu: Add ghc-hex.
* gnu/packages/haskell.scm (ghc-hex): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1d487386c1..73160e42c6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8375,4 +8375,24 @@ Date in Haskell.")
are the bottleneck of web servers.")
(license license:bsd-3)))
+(define-public ghc-hex
+ (package
+ (name "ghc-hex")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hex-" version "/"
+ "hex-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1v31xiaivrrn0q2jz8919wvkjplv1kxna5ajhsj701fqxm1i5vhj"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/hex")
+ (synopsis "Convert strings into hexadecimal and back")
+ (description "This package provides conversion functions between
+bytestrings and their hexademical representation.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here