summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:24:00 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:32:59 +0200
commit556f173904675a18cfd0dcbc9ed21c1c499e33bb (patch)
tree002eb794702b2b267219c202668275b5a6bd559f
parent932653ff375f4e27dcad61658d4188c24df8b8c3 (diff)
downloadguix-patches-556f173904675a18cfd0dcbc9ed21c1c499e33bb.tar
guix-patches-556f173904675a18cfd0dcbc9ed21c1c499e33bb.tar.gz
gnu: Add ghc-http-conduit.
* gnu/packages/haskell.scm (ghc-http-conduit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a2d26afcc3..9d03e5600f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8606,4 +8606,64 @@ based WAI (Web Application Interface in Haskell).")
a WAI handler, via the native Haskell TLS implementation.")
(license license:expat)))
+(define-public ghc-http-conduit
+ (package
+ (name "ghc-http-conduit")
+ (version "2.2.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "http-conduit-" version "/" "http-conduit-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "03na2nbm9la0shlijvjyb5mpp1prfskk4jmjy8iz707r0731dbjk"))))
+ (build-system haskell-build-system)
+ ;; FIXME: `httpLbs TLS` in test-suite `test` fails with
+ ;; ConnectionFailure getProtocolByName: does not exist (no such protocol
+ ;; name: tcp)
+ (arguments `(#:tests? #f))
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-client-tls" ,ghc-http-client-tls)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-exceptions" ,ghc-exceptions)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-connection" ,ghc-connection)
+ ("ghc-warp-tls" ,ghc-warp-tls)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-text" ,ghc-text)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-network" ,ghc-network)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-wai-conduit" ,ghc-wai-conduit)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-cookie" ,ghc-cookie)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-resourcet" ,ghc-resourcet)))
+ (home-page "https://hackage.haskell.org/package/http-conduit")
+ (synopsis "HTTP/HTTPS client with conduit interface")
+ (description "This library uses attoparsec for parsing the actual
+contents of the HTTP connection. It also provides higher-level functions
+which allow you to avoid direct usage of conduits.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here