summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2022-06-08 19:05:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-01 10:33:01 +0200
commit525457cc8b534cde0d98abee458248706ebb455a (patch)
treed963830a4d596b3f9ac4ffe28e162bfff71052c4
parent3cefd8ba5faec61b30a09b0bd6f01074623929ca (diff)
downloadguix-patches-525457cc8b534cde0d98abee458248706ebb455a.tar
guix-patches-525457cc8b534cde0d98abee458248706ebb455a.tar.gz
gnu: Add r-gstat.
* gnu/packages/cran.scm (r-gstat): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7cd3fc1d82..fdf4a3cc31 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33557,3 +33557,26 @@ and trajectories; utility functions for plotting data as map sequences (lattice
or animation) or multiple time series; methods for spatial and temporal
matching or aggregation, retrieving coordinates, print, summary, etc.")
(license license:gpl2+)))
+
+(define-public r-gstat
+ (package
+ (name "r-gstat")
+ (version "2.0-9")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "gstat" version))
+ (sha256
+ (base32
+ "19m4zcj1qvg6gs8yjr5ijvd6rrv4av5yp5rmhnb88f0m5qn06b0j"))))
+ (properties `((upstream-name . "gstat")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-lattice r-sp r-zoo r-spacetime r-fnn))
+ (home-page "https://github.com/r-spatial/gstat/")
+ (synopsis "Spatial and spatio-temporal geostatistical modelling,
+prediction and simulation")
+ (description
+ "This package enables variogram modelling, including: simple, ordinary and
+universal point or block (co)kriging; spatio-temporal kriging; and sequential
+Gaussian or indicator (co)simulation. It includes variogram and variogram map
+plotting utility functions, and supports @command{sf} and @command{stars}.")
+ (license license:gpl2+)))