summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <brian@debian>2019-12-03 17:23:50 -0800
committerBrian Leung <brian@debian>2019-12-07 22:16:32 -0800
commit4a6f2cee203bf43c052ccc133463e31f8b78465c (patch)
treeaace4c6339a647feeca537be85a49cd611d6d6d4
parentab9feebb31c85bc7e34a3dbc07c2796ff9ddae3d (diff)
downloadguix-patches-4a6f2cee203bf43c052ccc133463e31f8b78465c.tar
guix-patches-4a6f2cee203bf43c052ccc133463e31f8b78465c.tar.gz
gnu: Add emacs-repl-toggle.
* gnu/packages/emacs-xyz.scm (emacs-repl-toggle): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e158c3653..dbd7f7b592 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20200,3 +20200,25 @@ each slide with left/right keys.")
execution of buffer-exposing commands.")
(license license:gpl3+)))
+(define-public emacs-repl-toggle
+ (package
+ (name "emacs-repl-toggle")
+ (version "0.6.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tomterl/repl-toggle.git")
+ (commit version)))
+ (sha256
+ (base32
+ "12h3xxja3isnhvrqx7m2g7a5d8h68cc85pbqyhiipfxyafyl1yxd"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-fullframe" ,emacs-fullframe)))
+ (home-page "https://github.com/tomterl/repl-toggle")
+ (synopsis "Switch to and from current major mode's REPL")
+ (description "This package provides a function to switch to and from a
+REPL appropriate to the current major mode.")
+ (license license:gpl3+)))