summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-12-01 00:19:55 -0600
committerEric Bavier <bavier@member.fsf.org>2014-12-09 12:02:08 -0600
commit31f3976a21dddaeca5efad1ff90dfae083d66943 (patch)
treef3f9b981adc8f68b9e4adeb9e84a45397036c95f
parent2e66590aad50c6cb6fd39f2d757759874fe19736 (diff)
downloadguix-patches-31f3976a21dddaeca5efad1ff90dfae083d66943.tar
guix-patches-31f3976a21dddaeca5efad1ff90dfae083d66943.tar.gz
gnu: Add perl-file-which.
* gnu/packages/perl.scm (perl-file-which): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8d25ef3838..d7ca131353 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -276,3 +276,25 @@ bin as is also commonly used) paths of your Perl distribution.")
(home-page (string-append "http://search.cpan.org/~adamk/"
"Test-Script-" version))
(license (package-license perl))))
+
+(define-public perl-file-which
+ (package
+ (name "perl-file-which")
+ (version "1.09")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ "File-Which-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hxjyh9yrv32f3g8vrnr8iylzprajsac14vjm75kf1qnj1jyqbxp"))))
+ (build-system perl-build-system)
+ (native-inputs `(("test-script" ,perl-test-script)))
+ (synopsis "Portable implementation of the `which' utility")
+ (description
+ "File::Which was created to be able to get the paths to executable
+programs on systems under which the `which' program wasn't implemented in the
+shell.")
+ (home-page (string-append "http://search.cpan.org/~adamk/"
+ "File-Which-" version))
+ (license (package-license perl))))