summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2022-06-08 19:05:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-01 10:33:01 +0200
commit1eeecb2b5ad6dd74a5341006a447af0c69137bde (patch)
treed4a6cb9f9de4c8e6e31793c16ca30d5ee6ae4821
parent5ae0d8a9d02b046222ba276b406fa48541a6b5dd (diff)
downloadguix-patches-1eeecb2b5ad6dd74a5341006a447af0c69137bde.tar
guix-patches-1eeecb2b5ad6dd74a5341006a447af0c69137bde.tar.gz
gnu: Add r-sungeo.
* gnu/packages/cran.scm (r-sungeo): New variable.
-rw-r--r--gnu/packages/cran.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5699495c6e..d5017a05c8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33644,3 +33644,52 @@ non-contiguous area cartograms.")
measurements easier. One can convert between metric and imperial units, or
calculate a dimension's unknown value from other dimensions' measurements.")
(license license:gpl3)))
+
+(define-public r-sungeo
+ (package
+ (name "r-sungeo")
+ (version "0.2.288")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "SUNGEO" version))
+ (sha256
+ (base32
+ "0c8y0ngx1020rw2v00rxmq8syd72f41ckik5sg7gigg7d80gi31w"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ ;; Fortunately, the package does not actually use
+ ;; rmapshaper, which has got a js/node dependency.
+ ;; The only occurrence is in R/point2poly_tess.R,
+ ;; where it is commented out.
+ (substitute* "DESCRIPTION"
+ (("rmapshaper,") ""))
+ (substitute* "NAMESPACE"
+ (("importFrom\\(rmapshaper,ms_dissolve\\)
+") ""))
+ #t))))
+ (properties `((upstream-name . "SUNGEO")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-automap
+ r-cartogram
+ r-data-table
+ r-dplyr
+ r-fasterize
+ r-httr
+ r-jsonlite
+ r-measurements
+ r-packcircles
+ r-purrr
+ r-rann
+ r-raster
+ r-rcpp
+ r-rcurl
+ r-rlang
+ r-sf
+ r-sp
+ r-spdep))
+ (home-page "https://github.com/zhukovyuri/SUNGEO/")
+ (synopsis "Sub-National Geospatial Data Archive: Geoprocessing Toolkit")
+ (description
+ "Tools for integrating spatially-misaligned GIS datasets. Part of the
+Sub-National Geospatial Data Archive System.")
+ (license license:gpl2)))