summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-06-30 06:20:31 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-06-30 06:51:34 -0400
commit142068c6e4ae00490e8a9d57662fe502d16d737c (patch)
treecba52a168552694ace7210f6866421258a403fe6
parent9121fd78daa829f74346493b8debfb4629b8e5b9 (diff)
downloadguix-patches-142068c6e4ae00490e8a9d57662fe502d16d737c.tar
guix-patches-142068c6e4ae00490e8a9d57662fe502d16d737c.tar.gz
gnu: Add ruby-sentry-core.
* gnu/packages/ruby.scm (ruby-sentry-core): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 68e5d8dfd6..0792b66962 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12763,3 +12763,26 @@ Faraday-based API wrappers.")
(description "Bandwidth IRIS is a Ruby SDK for Bandwidth Phone Number
Dashboard. It is a Ruby Client library for IRIS / BBS API.")
(license license:expat)))
+
+(define-public ruby-sentry-core
+ (package
+ (name "ruby-sentry-core")
+ (version "5.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sentry-ruby-core" version))
+ (sha256
+ (base32 "141mrw8wghhsjvln9m6ld3hap3xc5v901jjiz007xywy25725hyd"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; No rakefile in gem.
+ `(#:tests? #f))
+ (propagated-inputs
+ (list ruby-concurrent
+ ruby-faraday))
+ (home-page "https://sentry.io/for/ruby/")
+ (synopsis "Client interface for the Sentry error logger")
+ (description "Sentry-Core provides a gem that provides a client
+interface for the Sentry error logger.")
+ (license license:expat)))