summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-06-28 15:22:49 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-06-30 11:23:39 +0200
commit9078c651e8d50e08b46e3b2da1c532c15af5ddb6 (patch)
treec155e7e6f523d2299d84fa14e183746fc85182a6
parent6804d2bc250aff676f63f464679dcf00259bc836 (diff)
downloadguix-patches-9078c651e8d50e08b46e3b2da1c532c15af5ddb6.tar
guix-patches-9078c651e8d50e08b46e3b2da1c532c15af5ddb6.tar.gz
gnu: Add r-mathjaxr.
* gnu/packages/cran.scm (r-mathjaxr): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb2519bcda..ed7d9b5032 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,7 +35,8 @@
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33459,3 +33460,22 @@ interface.")
purposes, illustrating/testing meta-analytic methods, and validating published
analyses.")
(license license:gpl2+)))
+
+(define-public r-mathjaxr
+ (package
+ (name "r-mathjaxr")
+ (version "1.6-0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mathjaxr" version))
+ (sha256
+ (base32
+ "0yf1sfkb2kjsplipl2v4k2gp20li9xzsynclg228sy0v243pdi7c"))))
+ (properties `((upstream-name . "mathjaxr")))
+ (build-system r-build-system)
+ (home-page "https://github.com/wviechtb/mathjaxr")
+ (synopsis "Using 'Mathjax' in Rd Files")
+ (description
+ "This package provides 'MathJax' and macros to enable its use within Rd files for
+rendering equations in the HTML help files.")
+ (license (list license:asl2.0 license:gpl3))))