summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:39:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:20 +0200
commitf93f4d508cccf472a52e560bd37d20e2788305d5 (patch)
tree093b1025274647923d3c6929da67625a21419ee6
parentbb926860bf0a32bcca5e4a5c06a03affb0427c97 (diff)
downloadguix-patches-f93f4d508cccf472a52e560bd37d20e2788305d5.tar
guix-patches-f93f4d508cccf472a52e560bd37d20e2788305d5.tar.gz
gnu: emacs-logview: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-logview)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f9e182d40b..8660793c4e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10524,15 +10524,15 @@ and doesn't require memorisation of commands.
(package
(name "emacs-logview")
(version "0.9")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/doublep/logview/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1vd11ppm46ldqsiwhqgw91p34gbjh1y82r9mxcn9r2gj65nvhxcp"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/doublep/logview.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qhzs75pxnaksbhczmpdcy2zmrqavlzkzss7ik5nv2wf9vs0sn02"))))
(propagated-inputs
`(("emacs-datetime" ,emacs-datetime)))
(build-system emacs-build-system)