summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:40:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:21 +0200
commitf903fa46eefe7ea23914df29dbf7e920dbb90a33 (patch)
tree440a875184251741f67a9fc314e9eb237bfae48a
parent609d10339de1def03f1da494b7adc0113804510b (diff)
downloadguix-patches-f903fa46eefe7ea23914df29dbf7e920dbb90a33.tar
guix-patches-f903fa46eefe7ea23914df29dbf7e920dbb90a33.tar.gz
gnu: emacs-ido-vertical-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-ido-vertical-mode)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 50be9cdf77..b6c492e0b4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11152,14 +11152,13 @@ bookmarks and history.")
(version "0.1.6")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/creichert/ido-vertical-mode.el/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/creichert/ido-vertical-mode.el.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0dprdxq8wvqd45dinwj92k0kixr07c8xvspa6i613mjcpxgwjg53"))))
+ (base32 "1lv82q639xjnmvby56nwqn23ijh6f163bk675s33dkingm8csj8k"))))
(build-system emacs-build-system)
(home-page "https://github.com/creichert/ido-vertical-mode.el")
(synopsis "Makes ido-mode display vertically")