summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 14:49:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 20:42:53 +0200
commitd1bdead83842d12208fd00eef7de9fdbff5fee53 (patch)
tree44fe0249fe50933ee26e42a955710168ea1db327
parent31a9003d4f47fe54df61d2313728bc09a21f20d0 (diff)
downloadguix-patches-d1bdead83842d12208fd00eef7de9fdbff5fee53.tar
guix-patches-d1bdead83842d12208fd00eef7de9fdbff5fee53.tar.gz
gnu: Add python-aplus.
* gnu/packages/python-science.scm (python-aplus): New variable.
-rw-r--r--gnu/packages/python-science.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index bf7c7ce45f..90809e8e56 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1222,3 +1222,20 @@ stack such as numpy arrays or pandas and xarray data structures. These are
out of the scope of the main traitlets project but are a common requirement to
build applications with traitlets in combination with the scipy stack.")
(license license:bsd-3)))
+
+(define-public python-aplus
+ (package
+ (name "python-aplus")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aplus" version))
+ (sha256
+ (base32 "1rznc26nlp641rn8gpdngfp79a3fji38yavqakxi35mx2da04msg"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/xogeny/aplus")
+ (synopsis "Promises/A+ for Python")
+ (description "This package is an implementation of the Promises/A+
+specification and test suite in Python.")
+ (license license:expat)))