summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:39:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:20 +0200
commit8d7f5c55a7bb67162f6dac64ed8948f939f27f0e (patch)
tree51f543b955299d805b6e935c2051343d752a2638
parent0dac411dc15f6c7fc52fb43f929cbb3c82d5c369 (diff)
downloadguix-patches-8d7f5c55a7bb67162f6dac64ed8948f939f27f0e.tar
guix-patches-8d7f5c55a7bb67162f6dac64ed8948f939f27f0e.tar.gz
gnu: emacs-benchmark-init: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-benchmark-init)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 338b970b4e..6577cb7aed 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10574,15 +10574,15 @@ functions.")
(package
(name "emacs-benchmark-init")
(version "1.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dholm/benchmark-init-el/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0szyqr4nncwz4vd5gww1vz31kf9r2lx25p4d0d09pm35974x53kz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dholm/benchmark-init-el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kyn1izm5sbqbp9whnhk9dn3yc7zy8bz5san5w3ivi3rpx15fh94"))))
(build-system emacs-build-system)
(home-page "https://github.com/dholm/benchmark-init-el")
(synopsis "Benchmark Emacs @code{require} and @code{load} calls")