summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-16 02:16:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-16 02:16:23 +0100
commit80ce42bdbf3f795ba6b91cebd472261b1e141a4a (patch)
tree9f3c6dfee02047fea593ef31f73acd0db66bf9be
parent58f5fae7c40f1bca9adfe63c2e6a134f89da0c0c (diff)
downloadguix-patches-80ce42bdbf3f795ba6b91cebd472261b1e141a4a.tar
guix-patches-80ce42bdbf3f795ba6b91cebd472261b1e141a4a.tar.gz
gnu: python-argcomplete: Fix tests.
* gnu/packages/python.scm (python-argcomplete, python2-argcomplete)[native-inputs]: Add python-pexpect and tcsh.
-rw-r--r--gnu/packages/python.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 10f295fe93..90c9ecd413 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -87,6 +87,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages shells)
#:use-module (gnu packages statistics)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
@@ -12150,6 +12151,9 @@ specs from your Flask-Restful projects.")
(base32
"11bwiw6j0nilgz81xnw6f1npyga3prp8asjqrm87cdr3ria5l03x"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-pexpect" ,python-pexpect)
+ ("tcsh" ,tcsh)))
(home-page "https://github.com/kislyuk/argcomplete")
(synopsis "Shell tab completion for Python argparse")
(description "argcomplete provides extensible command line tab completion