summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:49:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:49:44 +0300
commit7d55bc5e2a9fd3c2e72b82090854ce86fa6e44a1 (patch)
tree0fc101336939a84013695433d6e7c4dfc1576abf
parent50566124d10faa3205700448fab28b56c6408127 (diff)
downloadguix-patches-7d55bc5e2a9fd3c2e72b82090854ce86fa6e44a1.tar
guix-patches-7d55bc5e2a9fd3c2e72b82090854ce86fa6e44a1.tar.gz
gnu: Adsd python-transaction.
* gnu/packages/python-web.scm (python-transaction): New variable.
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3e358056b8..f23467bf8e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4227,3 +4227,27 @@ modified BTree data structure. The trees are optimized for use inside ZODB's
\"optimistic concurrency\" paradigm, and include explicit resolution of
conflicts detected by that mechanism.")
(license license:zpl2.1)))
+
+(define-public python-transaction
+ (package
+ (name "python-transaction")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "transaction" version))
+ (sha256
+ (base32
+ "0bdaks31bgfh78wnj3sij24bfysmqk25crsis6amz8kzrc0d82iv"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-zope-interface" ,python-zope-interface)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/zopefoundation/transaction")
+ (synopsis "Transaction management for Python")
+ (description "This package contains a generic transaction implementation
+for Python. It is mainly used by the ZODB.")
+ (license license:zpl2.1)))