summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 01:25:41 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:10 -0500
commit79d9326f621476e43a80332de801c08592af64d8 (patch)
treef654a949df8cde339232e0cd7de7203a7298a8be
parent92db1a887f6cd294f06e760debe3a83fc67d7f68 (diff)
downloadguix-patches-79d9326f621476e43a80332de801c08592af64d8.tar
guix-patches-79d9326f621476e43a80332de801c08592af64d8.tar.gz
gnu: ghc-logict: Update to 0.7.0.2.
* gnu/packages/haskell-xyz.scm (ghc-logict): Update to 0.7.0.2. [native-inputs]: Add 'ghc-tasty' and 'ghc-tasty-hunit'.
-rw-r--r--gnu/packages/haskell-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 277f7d8305..7f0b3b3776 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5904,7 +5904,7 @@ back-ends.")
(define-public ghc-logict
(package
(name "ghc-logict")
- (version "0.6.0.2")
+ (version "0.7.0.2")
(source
(origin
(method url-fetch)
@@ -5914,8 +5914,11 @@ back-ends.")
".tar.gz"))
(sha256
(base32
- "07hnirv6snnym2r7iijlfz00b60jpy2856zvqxh989q0in7bd0hi"))))
+ "1xfgdsxg0lp8m0a2cb83rcxrnnc37asfikay2kydi933anh9ihfc"))))
(build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "http://code.haskell.org/~dolio/")
(synopsis "Backtracking logic-programming monad")
(description "This library provides a continuation-based, backtracking,