summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:40:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:21 +0200
commit6b746c89ac17088df946cd5a5483d6f282c40c52 (patch)
tree076f4f6153d8cdeef12325f28958061d06c62de3
parentf903fa46eefe7ea23914df29dbf7e920dbb90a33 (diff)
downloadguix-patches-6b746c89ac17088df946cd5a5483d6f282c40c52.tar
guix-patches-6b746c89ac17088df946cd5a5483d6f282c40c52.tar.gz
gnu: emacs-wordgen: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-wordgen)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b6c492e0b4..54bd989478 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11171,13 +11171,13 @@ bookmarks and history.")
(version "0.1.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Fanael/wordgen.el/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Fanael/wordgen.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1h2iyixdm49h53pwj9ics9gb9h3g6wa4hainpnjg6mfarf49jkmg"))))
+ (base32 "06vbc9ycz1nbjwjkg99y3lj6jwb6lnwnmkqf09yr00jjrrfhfash"))))
(build-system emacs-build-system)
(home-page "https://github.com/Fanael/wordgen.el")
(synopsis "Random word generator")