summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 22:52:43 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:05 -0500
commit65a16a4500132c1bcf3de910cc2ebbb9ac748f27 (patch)
tree2a24bbb59c2dcb203c738b4a3e96df47daf6ac2d
parente71f316f7580d49a4f699934bc93c514ffd3ef2b (diff)
downloadguix-patches-65a16a4500132c1bcf3de910cc2ebbb9ac748f27.tar
guix-patches-65a16a4500132c1bcf3de910cc2ebbb9ac748f27.tar.gz
gnu: ghc-hashable: Update Cabal file to r1.
* gnu/packages/haskell-xyz.scm (ghc-hashable): Update Cabal file to r1. (ghc-hashable-bootstrap): Splice in arguments from 'ghc-hashable'.
-rw-r--r--gnu/packages/haskell-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1dd25f2e5f..3bd6c140fe 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4346,6 +4346,9 @@ Happy works in a similar way to the yacc tool for C.")
(base32
"1gra8gq3kb7b2sd845h55yxlrfqx3ii004c6vjhga8v0b30fzdgc"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("1" "197063dpl0wn67dp7a06yc2hxp81n24ykk7klbjx0fndm5n87dh3")))
(inputs
`(("ghc-random" ,ghc-random)))
(native-inputs
@@ -4367,7 +4370,9 @@ combine hash values.")
(package
(inherit ghc-hashable)
(name "ghc-hashable-bootstrap")
- (arguments `(#:tests? #f))
+ (arguments
+ `(#:tests? #f
+ ,@(package-arguments ghc-hashable)))
(native-inputs '())
(properties '((hidden? #t)))))