summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:40:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:21 +0200
commit609d10339de1def03f1da494b7adc0113804510b (patch)
tree43bfbff9f977cbb845695e8a5887f13712d31a60
parentfa8976d6caf910ee568f049e8209a05dc9ddfe60 (diff)
downloadguix-patches-609d10339de1def03f1da494b7adc0113804510b.tar
guix-patches-609d10339de1def03f1da494b7adc0113804510b.tar.gz
gnu: emacs-parinfer-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-parinfer-mode)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 50e73c129f..50be9cdf77 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11057,13 +11057,13 @@ macros, faces and variables. To enable call @code{highlight-defined-mode}. ")
(version "0.4.10")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/DogLooksGood/parinfer-mode/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DogLooksGood/parinfer-mode.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "06ba9qi59sm9ih9m38fbr8kj4qkvrm58n0c0ngfjz60gnr9x9pcv"))))
+ (base32 "0v97ncb0w1slb0x8861l3yr1kqz6fgw1fwl1z9lz6hh8p2ih34sk"))))
(propagated-inputs
`(("emacs-dash" ,emacs-dash)
("emacs-rainbow-delimiters" ,emacs-rainbow-delimiters)