summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-07-02 13:47:23 -0500
committerEric Bavier <bavier@member.fsf.org>2014-07-02 13:47:23 -0500
commit5becd025107c4af728cfdaef6ddc6b473138e96f (patch)
tree6fa16eb130a8d08c68bb773f26d56dfae110afd9
parent221ed17a580f5e3df0347cc83064bb50c41d1231 (diff)
downloadguix-patches-5becd025107c4af728cfdaef6ddc6b473138e96f.tar
guix-patches-5becd025107c4af728cfdaef6ddc6b473138e96f.tar.gz
gnu: gnome: Version splitting and line wrapping.
* gnu/packages/gnome.scm (orbit2): Wrape code to 80 characters. Use string-split/string-join to get version major/minor numbers. (libbonoboui): Likewise.
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4f672ba227..cee0c3476d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -694,24 +694,25 @@ featuring mature C, C++ and Python bindings.")
(version "2.32.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "mirror://gnome/sources/" name "/" (string-take version 4) "/" name "-"
- version
- ".tar.bz2"))
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (string-join (take (string-split version #\.) 2)
+ ".")
+ "/" name "-" version ".tar.bz2"))
(sha256
(base32 "0swp4kk6x7hy1rvd1f9jba31lvfc6qvafkvbpg9h0r34fzrd8q4i"))))
(build-system gnu-build-system)
(arguments
;; The programmer kindly gives us a hook to turn off deprecation warnings ...
- `(#:configure-flags '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
- ;; ... which they then completly ignore !!
- #:phases
- (alist-cons-before
- 'configure 'ignore-deprecations
- (lambda _
- (substitute* "activation-server/Makefile.in"
- (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))
- %standard-phases)))
+ `(#:configure-flags
+ '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+ ;; ... which they then completly ignore !!
+ #:phases
+ (alist-cons-before
+ 'configure 'ignore-deprecations
+ (lambda _
+ (substitute* "activation-server/Makefile.in"
+ (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))
+ %standard-phases)))
(inputs `(("popt" ,popt)
("libxml2" ,libxml2)))
;; The following are Required by the .pc file
@@ -1063,9 +1064,9 @@ widgets built in the loading process.")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://gnome/sources/" name "/" (string-take version 3) "/" name "-"
- version
- ".tar.bz2"))
+ "mirror://gnome/sources/" name "/"
+ (string-join (take (string-split version #\.) 2) ".")
+ "/" name "-" version ".tar.bz2"))
(sha256
(base32
"1kbgqh7bw0fdx4f1a1aqwpff7gp5mwhbaz60c6c98bc4djng5dgs"))))