summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:36:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:17 +0200
commit5521a3e74656fbd0dbd3fa25e3abd9815f6cd835 (patch)
tree5b36d2898280a8e84abc183e0c8d63a4968035ae
parent40cc1884efa2aab5441c396166d97a33568849ae (diff)
downloadguix-patches-5521a3e74656fbd0dbd3fa25e3abd9815f6cd835.tar
guix-patches-5521a3e74656fbd0dbd3fa25e3abd9815f6cd835.tar.gz
gnu: emacs-list-utils: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-list-utils)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 959a8c13ce..e9f5766909 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9437,13 +9437,13 @@ and @code{erc-send-modify-hook} to download and show images.")
(version "0.4.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/rolandwalker/list-utils/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rolandwalker/list-utils.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1xc1xh8c82h5gdjbgpdsdclgwxkxbb7h3x3a2bscpm41g8pnan4p"))))
+ (base32 "0ql159v7sxs33yh2l080kchrj52vk34knz50cvqi3ykpb7djg3sz"))))
(build-system emacs-build-system)
(home-page "https://github.com/rolandwalker/list-utils")
(synopsis "List-manipulation utility functions")