summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 22:59:23 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:01 -0500
commit49367c92a1bb29f76c7f1a4b2c1eee974c3f6a0f (patch)
tree4f5a1e91a72035e151f22df9a6fd2b6b8b70ab3c
parentc38746eb7b7918e5c45deffc5fbf7c093403ae51 (diff)
downloadguix-patches-49367c92a1bb29f76c7f1a4b2c1eee974c3f6a0f.tar
guix-patches-49367c92a1bb29f76c7f1a4b2c1eee974c3f6a0f.tar.gz
gnu: Add ghc-splitmix-bootstrap.
* gnu/packages/haskell-xyz.scm (ghc-splitmix-bootstrap): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f1e3081f92..e00883a7f2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9418,6 +9418,39 @@ splitting lists into parts, akin to the @code{split} function found in several
mainstream languages.")
(license license:bsd-3)))
+(define-public ghc-splitmix-bootstrap
+ (package
+ (name "ghc-splitmix-bootstrap")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "splitmix/splitmix-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k0amgkz7rvyz3lnw7m786ilnr1cibwhx9sc4qynq329gxan5r7w"))))
+ (properties '((hidden? #t)))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f))
+ (inputs
+ `(("ghc-random" ,ghc-random)))
+ (home-page "http://hackage.haskell.org/package/splitmix")
+ (synopsis "Fast and splittable pseudorandom number generator")
+ (description "This package provides a Pure Haskell implementation of the
+SplitMix pseudorandom number generator. SplitMix is a \"splittable\"
+pseudorandom number generator that is quite fast: 9 64-bit
+arithmetic/logical operations per 64 bits generated. SplitMix is tested
+with two standard statistical test suites (DieHarder and TestU01, this
+implementation only using the former) and it appears to be adequate for
+\"everyday\" use, such as Monte Carlo algorithms and randomized data
+structures where speed is important. In particular, it @strong{should not
+be used for cryptographic or security applications}, because generated
+sequences of pseudorandom values are too predictable (the mixing functions
+are easily inverted, and two successive outputs suffice to reconstruct the
+internal state).")
+ (license license:bsd-3)))
+
(define-public ghc-statevar
(package
(name "ghc-statevar")